Skip to content

アプリケーション内で をクリックすると、お使いのDataRobotバージョンに関する全プラットフォームドキュメントにアクセスできます。

データ

データ」タブには、自分と他のチームメンバーが選択したユースケースに現在リンクされているすべてのデータセットが一覧表示されます。 このタブにアクセスするには、ユースケースを開き、データをクリックします。

このタブでは、次の操作を行うことができます。

要素 説明
1 新規追加 データセット、エクスペリメント、ノートブックをユースケースに追加するか、新しいユースケースを作成します。
2 検索 特定のデータセットを検索します。
3 ソート データセット列を並べ替えます。
4 アクションメニュー Click the Actions menu to interact with a dataset:
  • Explore: View exploratory data insights.
  • Wrangle/Continue Wrangling: Perform data wrangling on datasets retrieved from a data connection.
  • Start modeling: Set up an experiment using the dataset.
  • Remove from Use Case: Removes the dataset from the Use Case, also removing access for any team members. データセットは引き続き データレジストリから使用できます。
5 アセットタイプアイコン 各アセットの前には、以下のアイコンのいずれかが表示されます。
  • : アセットが登録済みデータセットであることを示します。
  • : アセットがラングリングレシピであることを示します。

データを参照

データセットがワークベンチに登録されている間、DataRobotは探索的データ解析 (EDA1)も実行します。つまり、すべての特徴量を解析してプロファイリングし、特徴量型の検出、日付型特徴量の自動変換、特徴量の品質評価を行います。 登録が完了したら、EDA1の計算中に明らかになった情報を探索できます。

プレビュー

ワークベンチでの動的データセットのサポートは、デフォルトではオンになっています。

この機能が有効になっている場合:

  • データ接続を介して追加されたデータセットは、データレジストリとユースケースに動的データセットとして登録されます。
  • 接続を介して追加された動的データセットは、データレジストリで選択できます。
  • DataRobotは、動的データセットの探索的データインサイトを表示するときに、新しいライブサンプルを取得します。

機能フラグ: ワークベンチで動的データセットを有効にする

To open the data explore page:

  1. ユースケースで、データタブに移動します。
  2. Click the Actions menu next to the dataset you want to view and select Explore. または、データセット名をクリックしてインサイトを表示します。

  3. データセット内の各特徴量に対して、 ヒストグラムやサマリー統計など、さまざまな 特徴量の詳細が表示されます。

  4. 特定の特徴量をドリルダウンするには、上部にあるヒストグラムチャートをクリックします。

Dataset versioning

The data explore page supports dataset versioning, allowing you to access a history of data snapshots as well as create new snapshots from the same page. To access dataset versions, click the dropdown next to Data actions or open Dataset Versions in the right panel.

View dataset versioning in the data explore view.

  要素 説明
1 スナップショットポリシー Displays the selected dataset version. If the snapshot version is selected, DataRobot displays the date and time of the snapshot creation. Click the dropdown to access the following:
  • Version history: An abbreviated version history that displays the dynamic dataset (live data) and most recent snapshot.
  • + スナップショットを作成:表示しているデータセットのスナップショットを作成します。 After registration is complete, the new snapshot is listed as the latest version, and can also be accessed in the Use Case and Data Registry.
  • Select version: Opens Dataset Versions in the right panel.
2 データセットバージョン Displays a version history of the dataset. Click a dataset to view a different version.
3 +スナップショットを作成/新しいバージョンをアップロード Allows you to add additional versions of the dataset, and after registration is complete, the new dataset is displayed in the version history. さらに、ユースケースとデータレジストリに追加されます。
  • If the snapshot policy of the original dataset is dynamic or snapshot,the + Create snapshot button is available, which creates a snapshot of the dataset you're viewing.
  • If the original dataset is static (i.e., uploaded as a local file), the Upload new version button is available, which allows you to upload updated local versions of the dataset.
Data actions for snapshot policies

The data explore page supports the following snapshot policies:

  • 動的:DataRobotはデータソースに接続され、ライブデータを使用して、選択されたデータ操作を実行します。
  • Snapshot: A fixed snapshot that is stored in DataRobot and used to perform the selected data action. This policy is recommended for repeatable experimentation if live data often changes.
  • Static: A local file used to perform the selected data action.

Feature list view

The Feature list view replaces the dropdown with a dedicated page to view, manage, and create feature lists.

Feature list tab open in the data explore view

To control the columns displayed here, click Settings and select the box next to the columns you want to view. 次に適用をクリックします。

Open feature list column settings.

Dataset actions

From the data explore page, you can perform the following actions:

Available dataset actions from the data explore view.

  要素 説明
1 データセット名 To rename the dataset, click on its name. To save your changes, click outside of the text field.
2 データのアクション Open the Data actions dropdown to perform one of the following actions with the dataset you're currently viewing:
  • Start wrangling: Perform data wrangling on the dataset. Only available for dynamic datasets.
  • Start modeling: Set up an experiment using the currently selected dataset version. By default, the latest version of the dataset is used.
  • Start feature discovery: Use Feature Discovery to perform multi-dataset, interaction-based feature creation
  • Download dataset: Download the dataset locally. Only available for snapshotted datasets.
  • Remove dataset: Remove the dataset from the Use Case. It will no longer be visible on the Data tab, however, it will be available in Data Registry and will not affect experiments created with the dataset.
3 Data Versions actions Under Dataset Versions, click the Actions menu to perform one of the following actions on a specific snapshot dataset:
  • Start modeling: Set up an experiment using this dataset.
  • Download dataset: Download the dataset locally. Only available for snapshotted datasets.
  • Delete: Removes the dataset from Version History, however, it will be available in Data Registry and will not affect experiments created with the dataset.

特徴量セット

プレビュー

ワークベンチでの特徴量セットのサポートは、デフォルトではオンになっています。

機能フラグ:ワークベンチでデータタブと特徴量セットタブを有効にする、ワークベンチで特徴量セットの作成を有効にする

データセットをユースケースに追加した後、DataRobotは EDAの一部として特徴量セットを生成します。 特徴量セットは、DataRobotでモデルの構築と予測に使用する特徴量のサブセットを制御します。 各モデルには特徴量セットが関連付けられています。

特徴量セットを使用して、次のようなことができます。

  • ターゲットリーケージの原因になっている特徴量など、何らかの理由でモデルで使用できない特徴量を削除する。
  • 有用でない特徴量(モデルのパフォーマンスを向上させない特徴量)を削除して、予測を高速化する。

自動作成された特徴量セットのいずれか(有用な特徴量、元の特徴量)を使用するか、 カスタム特徴量セットを作成できます。

特徴量セットの表示

エクスペリメントを設定する前に、探索的データインサイトを使用してさまざまな特徴量セットを探索してから、モデリングに使用する適切な特徴量セットを選択します。

特徴量セットのインサイトを探索するには:

  1. In the Data tab, click the Actions menu next to the dataset you want to view and select Explore. または、データセット名をクリックします。

  2. 特徴量セットにアクセスするには、ページ上部にあるドロップダウンをクリックし、使用可能な特徴量セットを選択します。 プレビューが更新され、選択したセットの特徴量だけが表示されます。

特徴量セットを作成

カスタム特徴量セットを作成するには:

  1. データセットの探索中に、ページ上部にあるドロップダウンをクリックし、+ 新しい特徴量セットを選択します。 特徴量ビューが開きます。

  2. カスタムセットに含めたい各特徴量の横にあるボックスを選択します。 次に、特徴量セットを作成をクリックします。

  3. 新しい特徴量セットの名前と説明(任意)を入力します。

  4. 変更を保存をクリックします。 これで、ドロップダウンで新しい特徴量セットにアクセスできるようになりました。

次のステップ

ここから、次のことができます。


更新しました June 7, 2024